سازندگان یک از پرکاربردترین کتابخانه های جاوااسکریپت یعنی jQuery اعلام کردند که دیگر نمی خواهند نسخه های قدیمی مرورگر مایکروسافت را پشتیبانی کنند.  بنابراین نسخه هایی که قبل از IE 9.0 عرضه شده با انتشار کتابخانه ی جدید jQuery 2.0  در اوایل سال 2013 دیگر قابلیت استفاده از آن را نخواهند داشت. سازندگان این کتابخانه می گویند طبق اگر بخواهند طبق نقشه راه عمل کرده و ویژگی های مورد نظر را به jQuery اضافه کنند، نسخه های قدیمی این مرورگر دیگر قابل پشتیبانی نیست.

سازندگان بعد از نسخه ی jQuery 1.8 پشتیبانی از نسخه های قدیمی تر مرورگر IE را حذف کرده و در واقع کمتر از یک ماه برای ارتقاط مرورگر IE فرصت داریم. در قدم اول واسط مخصوص مرورگر IE تغییر کرده و به شکلی بد نمایش داده می شود و در قدم بعدی با عرضه ی نسخه 1.9موارد زیادی از امکانات حذف یا ناقص می شود اما پلاگین های اضافی و واسط برنامه نویسی (API) جایگزینی برای بیشتر آنها عرضه می شود. قرار است چند نسخه با عنوان 1.9x نیز عرضه شود که برای تصحیح باگ‌های موجود در API جدید می باشد. با عرضه ی نسخه 2.0 پشتیبانی از نسخه های قدیمی حذف می شود ولی امکان استفاده از همان پلاگین ها و APIهای جایگزین وجود خواهد داشت.

کاربرانی که در وب سایت خود از jQuery استفاده می کنند و می خواهند مرورگرهای Internet Explorer نسخه های 6، 7 و 8 را نیز پشتیبانی کنند باید از نسخه ی 1.9 این کتابخانه بهره برده و آن را به نسخه های بعدی ارتقا ندهند. سایر کاربران مشکل خاصی با نسخه های جدید jQuery نخواهند داشت. با اینکه jQuery از همان ابتدا برای در نظر گرفتن تفاوت مرورگرهای مختلف ساخته شده اما سازندگان آن عقیده دارند که نسخه های قدیمی تر IE حدود 1 دهه است که مثل خاری در چشم سازندگان وب فرو رفته و پشتیبانی کردن آن بسیار مشکل شده است.

منبع: h-online